Forgot?

Ninja Xplorer: E_STRICT error?

Reply Topic
Link to this post 31 Jul 12

Hello,
Joomla v1.5 (latest build)
physical path: public_html/joomla

is hosted on a university web server:

OS: SunOS 5.1; build date Feb 2005
Server API: Apache 2.0
Php: 4.3.1
I don't have root or super user privs. Also the policy allows only secure FTP or SSH (e.g. Puty) to my public_html dir. Hence, the Joomla v1.5 FTP layer will not work and my motivation to use a Joomla backend file management extension.

The web server does not run suPHP (i.e. PHP scripts are run under the WWW user:group). I unzipped the Joomla install locally, then uploaded all contents via sftp. Ran the install procedure, no issues, and have a working site. I requested the web admin to chown the Joomla folder recursively to www:www. After that I can install extensions, such as Ninja Xplorer.
Xplorer appears to work but there is a persistent error at the top of the GUI. Is this an issue?

Notice: Use of undefined constant E_STRICT - assumed 'E_STRICT' in /[my domain]/public_html/joomla/administrator/components/com_ninjaxplorer/libraries/FTP/Socket.php on line 31
Directory: ../

Link to this post 01 Aug 12

Hi kirkw,

This isn't an error, it is a "Notice". PHP provides notices to developers as a 'hint' that something could be improved. Other than looking bad, it won't have any effect on the extension or Joomla.

We won't fix it (sorry about that) as the current version of NinjaXplorer is in maintenance-only mode... we will only touch it to fix security holes if any are found.

It's unfortunate that you are running on PHP 4, as many extensions will fail to work on it (Joomla 2.5 won't work at all on anything older than PHP 5.2).

Good luck.

Mark

Forums Ninja Xplorer Ninja Xplorer: E_STRICT error?