Forgot?

Can't Save Settings in Joomla 1.7

Reply Topic
Link to this post 12 Dec 11

I installed Ninja Clicky into my Joomla 1.7.3 system. It installed fine but it isn't working as far as I can tell.

I can open the module preferences but when I try to set the position and then try to save and close the editor nothing happens. I get a "#" at the end of the URL which seems bad.

Also, I can't close that window at all and I don't see a text input for the ID I need to enter.

What am I doing wrong?

James.

Link to this post 13 Dec 11

Hi James.

Thanks for trying Ninja Clicky.

I've just checked it out on my J1.7.3 setup but couldn't replicate your issue.
Can you tell what browser you are using? What happens if you try a different browser?

Also check if you have a third party javascript running in the background. Extensions that are installed for improving the Admin site (Backend) etc, could cause conflicts with other extensions. Try to disable such extensions if you have any installed and see if Ninja Clicky behaves normal afterwards.

I hope this helps.
Let us know how it goes.

Kind regards,
John

Link to this post 26 Dec 11

Hi vuillemet,

Sorry to hear you are having trouble with Ninja Clicky.
Please, we prefer to write in English as people all over the world are coming here for support.

To give an answer to your question, I believe it's not a Ninja Clicky issue.
Please refer to my previous post. like I said, I was not able to replicate the issue.
So I have no solid clue where this behavior is coming from.

In case things won't solve, if you want I would like to inspect your problem by providing me super admin access. This way it's easier to see what's going on.

You may also post screenshots of the settings from Ninja Clicky, sometimes this will help too.

In case you don't mind to provide me super admin access, you can send the credentials to:

john at ninjaforge dot com.

Thank you.

Kind regards,
John

Link to this post 27 Dec 11

Hi vuillemet,

Thanks for your trust with giving me super admin access to your site, much appreciated.
I've spend quit some time at your sites backend to inspect what was going on.
After a while I was able to get Ninja Clicky to work.
I'm still not sure what caused the behavior you experienced.

At first I thought it was the No Number extension (framework) and its related Advanced Module Manager plugin. This looked like the issue I described in my first reply: other extensions used for backend improvement can cause trouble to other extensions to work properly.

Apparently by disabling those (No Number framework, Advanced Module Manager and some others), Ninja clicky still didn't display the Parameter section within the module's settings.

Like I said in my first reply I still wasn't able to replicate the behavior on my own setup.
So I compared things over again but couldn't find anything suspicious.
Then I decided to inspect the XML file that comes with the installation of Ninja Clicky.
I did some changes with the description tag and suddenly Ninja Clicky was displaying the Parameter section and the toolbar buttons worked as expected too. Even when I enabled the No Number extensions again.

Now, this is not a proper solution or fix because the XML is just alright.
I still suspect other thirs party extensions causing this behavior, but I can't tell wich one.
Could also be a server related issue, I don't know.
All I can say I was able to get Ninja Clicky to work in a lucky way I suppose.
Normally there's an explanation why things don't work but this time I've don't have a solid one.

In the end I would advise not to install too much extensions unless you need to.
The more extensions you install, the more trouble (conflicts) you can expect.
I see this as the main reason why Ninja Clicky didn't work as it should.
Please, just keep this in mind for the futrure. This is meant as a friendly advise.

You can now use Ninja Clicky, enjoy ;)

I hope you understand what the situation was.
If you have further questions, please feel free to ask.

Kind Regards,
John

Link to this post 28 Dec 11
Link to this post 29 Dec 11

I have the same problem: Joomla 1.7.3
I have tried to install the module, the installation do, but it isn't possible to manage the Module:
In the Module Manager:Module do not appear
In Extension Manager > Manage appear Ninja Clicky Location: Site Type:Module, Version 2.0.0, Date :October 2007, Folder N/A, ID 10036 .
One things: de Joomla 1.7.3 it is a result of an migration - upgrade from 1.5

Any suggestions?
Thank you

Link to this post 29 Dec 11

Now,
i have uninstalled the ninja Clicky module, and reinstalled it.
After the new installation the module are fisibile in the Module Manager, but it is not possible to do any setup.
And whwn i do close the windows explorer give me te error:
Webpage error details


Message: 'task' is null or not an object
Line: 4
Char: 242
Code: 0
URI: http://www.acerten.it/media/system/js/core.js

Link to this post 29 Dec 11

Hi carlo1212,

Open up mod_ninja_clicky.xml from the package you've downloaded (or use your file manager at your server to edit the file directly).
Delete the description text between the <description> tags and upload/save the file.
Reload/refresh the settings page for Ninja Clicky.

This should do the trick.

I hope this helps.

Kind regards,
John

Link to this post 05 Jan 12

with the edited xml file, the module seems work, but it do not write the script in the page.
I have , naturally, put "Module Assignment" "on all pages".
Any suggest?
Thank you
Carlo

Link to this post 05 Jan 12

Hi Carlo,

Do you have a link to the page in question please?

Thanks.

Kind regards,
John

Link to this post 05 Jan 12

Hi Carlo,

Thanks for the link.

Try to set "Disable Javascript" to "Disable" within the Ninja Clicky module settings under Basic Options.
Leave "Invisible Mode" to "Disable".

I hope this helps.
Let us know how it goes.

Thanks.

Kind regards,
John

Link to this post 05 Jan 12

:-( ...still not work.
Note that position it is set to "::None::".

Thanks
Carlo

Link to this post 05 Jan 12

Hi Carlo,

Ok, thanks.
Do you mean that the module position is set to "none"?
You have to set the module position to an existing position of your current template.

Then set Disable Javascript to Enable.
And leave Invisible Mode to Disable.

I see a Get Clicky Badge at the end of the page. This not the default Clicky badge from Ninja Clicky.
I have no idea where this badge is coming from, do you?

Otherwise try to post a screenshot of an overview of all the settings of Ninja Clicky.

If you still encounter troubles, consider to send me a super admin account in order for me to inspect your issue at closer hand.

In case you consider. You may send the super admin credentials to john at ninjaforge dot com.

Thanks.

Kind regards,
John

Link to this post 05 Jan 12

The solution:

You have to set the module position to an existing position of your current template.

Then set Disable Javascript to Enable.
And leave Invisible Mode to Disable.

Now Work !!!! :-)
Thanks.

Kind regards,
Carlo

Link to this post 06 Jan 12

Hi Carlo,

Great to hear it's working now.
Thanks for your feedback.

Have a good weekend ;)

Kind regards,
John

Forums Ninja Clicky Can't Save Settings in Joomla 1.7