Forgot?

Problem with IE8

Reply Topic
Link to this post 12 Oct 11

Hi guys,

I'm having some troubles with the Ninja shadowbox Plugin.

I instaled it on a website that i'm developing and works fine in all browsers except (as usual) IE 7,8 and 9.

Find below the url of the website (it's a developing server)

http://desarrollo7.buyto.es/index.php?option=com_content&view=article&id=123:yoga-posnatal&catid=45:portada&Itemid=159

(You have to click over the left image)

Thank you for your support and wonderful extensions!!

Link to this post 13 Oct 11

Hi MatiasV,

Welcome and thanks for the kind words.

Also thanks for providing the link.

I've tested the page in question in IE9 and Ninja Shadowbox works fine.
However, in IE7 and IE8 it didn't work as expected.

What you can try is the following:

Open the index.php file of your default template.
Paste the following code right after the opening <head> tag
(make sure it comes first):

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7; IE=EmulateIE9">

or

<http-equiv="X-UA-Compatible" content="IE=EmulateIE7; IE=EmulateIE9">

This piece of code makes your website run in IE7, 8 and 9 compatibility mode. This affects only IE browsers.

I hope this helps.
Let us know how it goes.

Kind regards,
John

Link to this post 13 Oct 11

Hi John,

Thank you for your answer, but unfortunately all your suggestions didn't have the solution to my problem.

If it helps, I enclosed a copy of the index.php file of my default template with the modification you've suggested.

Hope you can do something for me.

Thank you and best regards.

Matias

Link to this post 14 Oct 11

Hi Matias,

Thanks for your feedback.
I didn't see the file attached in your post, but by inspecting the page I noticed you modified the file correct.

Strange...

Can you try to choose a different script library within the settings of Ninja Shadowbox.
Go in to the settings and at the top right you can choose a library from the dropdown list.
As an alternate you can try the Dojo script instead of JQuery.
Also, try to play around with both of the "Include" options too, see if this helps.

Another thing is to leave the option "Fix Internet Explorer 8" set to "No" as long you have added he meta tag (described in my previous post) to the header of the index.php file.

Let us know how it goes.

Kind regards,
John

Forums Ninja Shadowbox & Ninja ShadowPanel Problem with IE8