Koowa broke my complete joomla installation

Reply Topic
Link to this post 15 Jul 11


I installed NB last night and it appears to be really good. When I went to configure it I noticed anothe item in the menu koowa so I clicked on it, and since that time the site has completely broken.

I now get this error message when accessing the front or back end of the site.

Fatal error: Class 'KFactory' not found in /address of installation/plugins/system/koowa.php on line 42

I have searched through help and cant find anything. How can I fix this and get the site back running again?

I am using a recent install of Joomla 1.3.2.



Link to this post 15 Jul 11

btw that should be Joomla 1.5.23

I got the site work again by copying some files from the plugin folder of the .zip to plugins/system

but I must say that NB still doesn't work correctly. I'm going to uninstall it until this is more stable.


Link to this post 15 Jul 11

Hi Mike,

I'm sorry your site was taken offline by this error.

There isn't a Koowa menu item, so I assume you were in the Joomla Plugin Manager and unpublished the Koowa plugin.

The only way to fix this is to go into the database and publish the Koowa plugin there.

Are you familiar with phpmyadmin, and do you have access to it? Your web host control panel should have phpmyadmin or some other database management script that you can use to look through your database.

You need to look for the table called xxx_plugins. This is usually called jos_plugins, but yours may be different. Go into the table and view all the rows in it. You should see a row for every plugin on your website. Look for the row for "System - Koowa". Open it up and you will see one of the fields is titled "published". Make sure the value of that field is "1". See the attached screenshot.

If this sounds scary to you, I would be happy to log in and fix it for you. Just email me your web host control panel username and password, and link to it, and I will sort it out.

Kind regards,

You don't have access to view the attachments in this post.
Link to this post 15 Jul 11

I forgot to mention... to email us your web host control panel details, the address is


Link to this post 15 Jul 11

Hi Mike,

Looks like you edited your earlier post instead of replying to me.

If it doesn't work properly, it is likely there is a conflict with something else on your site or your server, and not a problem with Ninjaboard, which is about as stable as software could be.

We would be happy to help you work through the problems when you next want to try Ninjaboard, so do let us know when that happens. You will of course need to be a little more descriptive than "doesn't work correctly". :)

Thanks for trying Ninjaboard.

Kind regards,

Link to this post 15 Jul 11

Hi Mark,

Thanks for your quick response. After I fixed the koowa malarkey I was getting 500 error messages and something about a call to a ninjaboard database.

I have uninstalled it for now, although some plugins remain. Koowa has also magically disappeared from the component menu. I suspect that it was something that just got messed up during the installation, rather than our site which is a virgin install.

Based on your statement about Ninjaboard's stability and your fast response time I will try Ninjaboard again. Perhaps later today if I can configure the rest of the site...


Link to this post 15 Jul 11

Glad to hear that, Mike.

When you do the installation, watch to make sure all packages are installed and it says "DONE". If you don't get that, then post here telling us what you saw and we will try and help you get it working. If it installs fine, the next step is to go to the Ninjaboard Dashboard. When you first arrive there, you should see a message if Ninjaboard thinks there is something on your server that will prevent it working well.

Good luck!

Link to this post 15 Jul 11


I tried to install it again and it appeared to install correctly. It said DONE and when I navigated to Dashboard I got this error message:

500 - An error has occurred.

Class [ComNinjaDatabaseBehaviorNestable] not found in file [/webaddress/administrator/components/com_ninja/databases/behavior/nestable.php]

Any ideas?


Link to this post 15 Jul 11

Does that file exist?

If not does com_ninja exist? On normal installs com_ninja should be there.

Btw, the magically disappearing menu items are by design. Framework components that only serve as reusable code for other extensions (to keep the codebase better maintained and easier updated) are not supposed to be used as regular components.
They got no UI, and put plainly they don't do anything on their own, they're abstract.

Since you got it working again it sounds like only the ajax reliant steps of the installer code failed, while the PHP code by itself were successful.

I just noticed that the koowa system plugin have been updated with a few new fixes and workarounds for 3rd party extensions in the onAfterInitialise function. Which is where your error about KFactory happened.
And I see that this code runs without checking if Suhosin or MySQLi not being enabled caused the framework not to load during __construct.

I'm going to do some tests and patch were necessary.

Thanks for reporting!

Link to this post 16 Jul 11

Hi Stian,

As far as I know com_ninja is there. In the components folder I have com_ninja and com_ninjaboard.
com_ninja contains two folders, administrator and media. com_ninjaboard contains commands, controllers, databases, iconsets, templates, themes and views.

I installed it as by uploading the files from /packages, although I think it installed when I uploaded the main file.

What can I do to fix this?


Link to this post 17 Jul 11

Ok, so I assume you checked that /administrator/components/com_ninja/databases/behaviors/nestable.php also exists?

Now what really struck me with your error message is that it says it checked this file:
But that file actually do not exist, so it should say something along the lines of "File not found".
The real file is located here:

So just so we're on the same page, here's what I assume about your system setup so far based on what you've told us, please let me know if I'm wrong in any of them:

  • Ninjaboard is the only extension installed on your site that is powered by Nooku Framework.

  • Your server got no PHP extensions specific for security, like Suhosin, that could interfere with how PHP executes and compiles code.

  • You are installing Ninjaboard v1.1.1, the latest stable.


Link to this post 18 Jul 11


I have checked and both files exist in both directories.
It's the only extension powered by Nooku and as far as I know there are no security extensions.


Link to this post 18 Jul 11

Only one of the two should exist.

Perhaps do a clean install of com_ninja by uninstalling it first, then reinstall.
The old files could be the culprit to the issue here. We do have cleanup scripts that should take care of this, but since you installed it manually it is possible that the maintenance scripts and upgrade scripts didn't run when they should.

Link to this post 16 Mar 18

I also download a software in my computer and after it I click on koowa and it completely broken my download, I think it is a kind of virus. There are so many articles available on buyessayfriend that are about this virus.

Forums NinjaBoard Koowa broke my complete joomla installation