Forgot?

NB RC1 error 500 in Backend

Reply Topic
Link to this post 04 Sep 10

Hi Stian,

I was installing the RC1 version last night and all went well.
Did a clean install by uninstalling the Beta first.
So, excited about the improvements I wanted to set up a totally new fresh board.

Unfortunately, there were some weird minor issue's I can't get resolved, no matter what I try.

1.
When saving a new created forum I get the message: '500 an error occured'.
When browsing back and click 'save' again the same issue.
When browsing back and click 'cancel' the new forum is added(?) to the list.
In case by clicking several times on 'save' and get the 500 error, browsing back and 'cancel', the same forum is listed more than once ( exactly the same amount when clicking 'save' ).
When editing this forum and save it afterwards it saves normal with no 500 error.


2.The Dutch translation ini files didn't install (just the English ini's).
Enabling 'language debugging' (for trying out, just in case. It should not be necessary, I guess) gives me also an error: JFile unable to read nl_NL.com_ninjaboard.ini.menu. Makes sence, the ini's aren't there. Same goes for Frontend.

I've attached screen-shots of the first issue.

[edit]
image file exceeds max values for upload, putting the screenshot this way due to readability:

click here for screenshot

[/edit]

Since my site isn't on-line yet, I will give you admin rights to take a look if you have the time and in case you think it's useful (login instructions send to support at ninjaforge dot com).

Please do you have any ideas what could be wrong?:)
Thanks.

Greets;)
John

Link to this post 04 Sep 10

Ok first off, NB does not ever need to uninstall before updating :)
It runs cleanup routines on every update, it'll never leave deleted files behind for instance.

The Dutch translation should be there.
If they weren't, then you shouldn't get a JFile error at all. And even if you did, it would say that JFile: file does not exist.
If it can't read it, then it means it's there, but got likely the wrong permissions, or wrong format.

Double check by checking that the files are in the package you downloaded, and if they are on your file system.

I'll do some debugging on this tomorrow and try and reproduce, and of course fix it on your server.
Your errors is a quite unique, it looks like it's unable to tell when to save, and when to add.

I got your email, thanks :)
I'll fix this ASAP.

Cheers,
Stian

Link to this post 05 Sep 10

Hi Stian,

Ok, thank you.

Did try some things though:

-permisions set to chmod 777
-reinstall over existing install. Didn't help.
-unpacked the tar.gz and uploaded folders by ftp (overwrite). At least the dutch ini's came thru. The error still persists.

Can't figure it out at the moment.:unsure:
I'm glad you will look in to it.
Take it easy, it has no priority.

Let me know if I can help.

Greets,;)
John

Link to this post 06 Sep 10

Hi John,

The forums bug got fixed in RC2, released minutes ago (it's just a quickfix release, so that bugfix is all it contains).

I found several issues on your site.
One of them is that most of your language folders like 'administrator/language/de-DE/', are unwritable.

This is the cause why the Ninjaboard install fails.
If it fails to move all its files during install, it will revert or error out.

I also noticed you got open_basedir set.
This is causing the built in internal installer on the dashboard (the Check for Updates? button) to fail.
You shouldn't define open_basedir, it creates more problems than it solves, just like php safe mode.

I didn't have super admin, so couldn't check your global config settings other than those found under Help -> System Info.

In any case, try correcting those folder permissions, by setting them to 755.
Go to Help -> System Info -> Directory Permissions to see what folders are unwritable.

I also tweaked the Chameleon style, by giving the menu item linking to Ninjaboard the following Page Class Suffix:
separator-currentcolor dark

Cheers,
Stian

Link to this post 07 Sep 10

Hi Stian,

Thank you very much for the debugging.

Last night I've noticed you were logged in.
It was a kind of funny experience.
I was working just on my site, let's say to make the final touch.
I was busy editing css styles regarding the RT-theme.
So not aware that you were there I did some tests and refreshed my browser.
At the same time I saw that the looks of Ninjaboard were slightly changed...
My reaction:...huh? What did I do to make that happen?...awsome...cool...!
Then in a second I realized it could be you doing that and it was you.:laugh:
Anyway, nice work, I like it very much.:woohoo:

Then I tried to keep track and did some changes you recommended.

First, sorry I didn't give you super admin rights.
I thought that admin rights were good enough, my bad, had to know better.
So you have super admin rights now, in case you need it in the future.

I've set the permissions to 755, all mentioned dirs are now writable.
I wasn't aware of this. I think it has to do when I did the manual upload for the unpacked NB folders by ftp, in fact I'm sure about that.
Thanks for pointing me.

About the open_basedir issue, I have no idea how to accomplish that.
I can't change that in my hosts cpanel or anywhere else.
I did a search on the net but again: hocus pocus:blush:
If you have the time, I need some help with this, please.

I'm going to install the RC2 today, great job.:)
Thank you very much for your precious time.

Ad Fundum ;)
John

Link to this post 07 Sep 10

Happy you like it :)

Regarding super admins, yeah it should be enough.
I don't need the rights to delete other super admins in order to debug, obviously.
But sadly Global Config only allows super admins, and that part is pretty vital for debugging unfortunately.

Regarding file permissions, ftp is likely the cause, yep.
You might want to check all the folders you uploaded by ftp, as Joomla isn't listing every folder with the wrong permissions.
It's only listing the permissions for core system folders that are crucial for installers to work.
But in order for NB to be able to install, the permissions needs to be right for NB folders as well.

Bottom line, if you have to ftp NB in order to install, then something is very wrong. Either a serious bug, or a serious server misconfiguration (most of the time the host, not the users fault).

Regarding open_basedir, we've had by now multiple reports of this.
And like said in another thread on this forum, I'm going to recode the curl call we're using, so that it don't fail when open_basedir is set.

So I'm gonna need access to your site a little while longer until it's fixed :)

Thanks,
Stian

Link to this post 07 Sep 10

Hi Stian,

Be my guest and de-bug away, you're free to do whatever you think is necessary :)
You have my trust in this of course.

The manual upload of the folders was just a test regarding the 500 error.
You're right, it's not the usual way to install extensions.
You know, sometimes when someone is a bit in despair one can make strange moves :laugh:
Anyway, checked the entire site and it's good to go.

Did install the RC2 today and it runs fine, no errors at all
Ninjaboard is looking (and working) great thanks to Chameleon ;)
[edit] Btw, I still wonder how you did found out that 'little' awsome tweak? [/edit]

I've read the other thread about the open_basedir issue.
I think it is a big relieve for me and many others when you recode the curl call, chapeau!
Last night I've read on the net what different methods there are to reroute open_basedir settings. Also that it has to do with certain restrictions and safety.
But like a said it didn't make much sense to me, it's beyond my knowledge. :S

As always, great job! :ninja:

Bottoms up ;)

John

Link to this post 08 Sep 10

Hi Stian,

I've tested the RC2 again on a sub-domain I've created.
Just for some debugging on a fresh Joomla! 1.5.20 install.
Kept thinking about the dutch ini's don't came thru the first time.
Honestly, it bothers me a little bit, because I want to check if I've to do some updates on the translation.:)

Again all went wel.
But there are some things I want to report. Just in case.

The Dutch language ini's, again didn't install.
By enabling language debugging I got the same message: Jfile unable to open...no such file or directory.
So I checked the filesystem on my host and there were no dutch ini's were they should be. Double checked chmod and the Global and User language settings in the Backend before I started.
Checked the RC2 package as well and they were just there were they belong.
Allthough I was sure about that.

By turning language debugging off the apache server had created two dutch ini's, one in the /administrator/language folder and one in the /language folder. Don't know for sure if this occured while debugging was on or after debugging was off. When opening these ini's it doesn't look familiar at all. Strange codes in it and most of all just English translated to English.
I think this is a normal behaviour or process and a host related matter. Just reporting.

Later on I was checking some files and noticed something strange in the manifest.xml
I'm not sure if this is the cause why the dutch ini's won't install.

[copied from clipboard]

<languages folder="administrator/language">
<language tag="de-DE">de-DE/de-DE.com_ninjaboard.ini</language>
<language tag="de-DE">de-DE/de-DE.com_ninjaboard.menu.ini</language>
<language tag="el-GR">el-GR/el-GR.com_ninjaboard.ini</language>
<language tag="el-GR">el-GR/el-GR.com_ninjaboard.menu.ini</language>
<language tag="en-GB">en-GB/en-GB.com_ninjaboard.ini</language>
<language tag="en-GB">en-GB/en-GB.com_ninjaboard.menu.ini</language>
<language tag="fr-FR">fr-FR/fr-FR.com_ninjaboard.ini</language>
<language tag="fr-FR">fr-FR/fr-FR.com_ninjaboard.menu.ini</language>
<language tag="nb-NO">nb-NO/nb-NO.com_ninjaboard.ini</language>
<language tag="nb-NO">nb-NO/nb-NO.com_ninjaboard.menu.ini</language>
</languages>
</administration>


<languages folder="language">
<language tag="de-DE">de-DE/de-DE.com_ninjaboard.ini</language>
<language tag="el-GR">el-GR/el-GR.com_ninjaboard.ini</language>
<language tag="en-GB">en-GB/en-GB.com_ninjaboard.ini</language>
<language tag="fr-FR">fr-FR/fr-FR.com_ninjaboard.ini</language>
<language tag="nb-NO">nb-NO/nb-NO.com_ninjaboard.ini</language>
</languages>

[/copied from clipboard]

Honestly I don't see any nl-NL language tags.

Like I said, just wanted to make this additional report next to the other issues on the forums.

I will also give you super admin rights for that sub domain.
You've access with the same account.
You can test and debug freely for server related issues if you find it usefull.
Other Ninja's may have access too.

The url is here

I hope this info is useful to you.

Greetings,;)
John

Link to this post 08 Sep 10

Hey,

Btw, I still wonder how you did found out that 'little' awsome tweak?

Check your menu item linking to Ninjaboard, and the Page class suffix ;)

Yeah, there are many guides on how to work around open_basedir, however none of them is really reliable.
So I just now finished the refactor, so the next Ninjaboard release will do "Check for updates" just fine with open_basedir on :)

Thanks for the report!
That information is indeed useful, we forgot to add the tags!!
That's indeed the cause why the dutch files weren't installed.
Sorry for your trouble! We'll do a quick RC3 with the tags added, and the open_basedir fix.

Thanks,
Stian

Link to this post 08 Sep 10

Hi Stian,

Check your menu item linking to Ninjaboard, and the Page class suffix

Oops...missed it, I saw you've mentioned it before...sorry :blush:

Thanks for the report!

No problem ;)

That information is indeed useful, we forgot to add the tags!!
That's indeed the cause why the dutch files weren't installed.
Sorry for your trouble!

It's all right, I'm glad we've solved it out and that I didn't came up with some nonsense. :)

We'll do a quick RC3 with the tags added, and the open_basedir fix.

Great job! Thanks! :cheer:

Greetings,

John

Link to this post 08 Sep 10

And done, all there's left now is the swedish translation seociable contributed, then RC3 is ready for release! :)

Link to this post 09 Sep 10

Amazing! how you guys jump into issue's and fix them as easy as they come. :woohoo:

Hmm...now I see...that could be a meaning behind NinjaForge, being a Ninja.
Having a mission and accomplish that without notice. :cheer:


Ad Fundum ;)
John

Link to this post 09 Sep 10

Our slogan is "Get on the Cutting Edge" after all ;)
Besides, I really love our updates system!
Someone reports a bug, we fixed it, push it on our update server, and the user can update from the dash.

That just never grows old :D

Forums NinjaBoard NB RC1 error 500 in Backend