Forgot?

Error creating feed file, please check write......

Reply Topic
Link to this post 08 Dec 09

Hi,

I installed the RSS Syndicator component & module fine and specified which categories I want to syndicate but when i click on the RSS image icon on site I get an error "Error creating feed file, please check write permissions."

Ive checked permissions for /components/com_ninjarsssyndicator/views/ninjarsssyndicator and its 755. There are other folders that are set to 755 for security (components, . Site is on shared hosting.

This is a client site and cant post URL here, so if you can help and need to see the site please PM me and I;ll send you all the details.

Appreciate your time.

Tnx,

G.

Link to this post 08 Dec 09

Hi gravity1,

Usually there is nothing we can do. You need to switch to a host which will give Joomla full read and write control, or turn on your joomla FTP layer in global configuration, or chmod the directory to 777.

Feel free to PM me via the icon under my avatar.

Cheers,
Mark

Link to this post 08 Dec 09

Hi Mark,

thx for quick reply!

joomla FTP layer in global configuration is on and working. What else could it be?

Cheers,

G.

EDIT: I get an error when i try and PM you too! :(

Link to this post 08 Dec 09

Did you try setting perms on the folder to 777?
Obviously not a good long-term solution security wise, but at least try so that we can confirm whether permissions really are the problem.

-M

Link to this post 08 Dec 09

Which folder? Most are set to 755 as site was hacked before! Cant risk again setting any to 777. Any other way of working this out?

Tnx

G.

Link to this post 08 Dec 09

Hi gravity1,

Don't worry, I don't think there is someone scanning your site 24hrs a day to find a folder with weak permissions. You can safely turn any folder to 777 for a few minutes while you test.

The folder is: /components/com_ninjarsssyndicator/feed

Let me know if it works at 777. Of course chmod back to 755 once you've tested properly.

Cheers,
Mark

Link to this post 09 Dec 09

Hi gravity1,

I got your PM, and that is definitely a bug in the extension. It seems to completely break with SEF URL's.

This has been posted to the tracker and will hopefully be fixed soon.

Mark

Link to this post 09 Dec 09

Oh.. so its useless to me? I need a solution that works with SEF urls as all my client sites are like this for SEO.

Regards,

Alan

Link to this post 09 Dec 09

Hi Alan,

Unfortunately yes; until we fix it, it is useless to you.

I hope you can understand that we don't have developers waiting around doing nothing. Everyone has work to do, extensions to develop, and bugs to fix.

This issue was reported 1 day and 16hrs ago. It was confirmed as a bug and added to our internal bug tracker 8hrs ago. It will make it's way up a queue and when its time comes, be fixed.

We do our best developing free extensions for you and others, and work hard to fix issues when they are found. Please be patient as we work on this issue.

I'm truly sorry that this bug exists, and give you my word that it will be fixed. I can't do more then that I'm afraid.

Kind regards,
Mark

Link to this post 09 Dec 09

No problem. I thought this would have have shown up before for other users as a lot of people use SEF URLs no?

Looking forward to the fix and appreciate your time.

Regards,

Alan

Link to this post 10 Dec 09

Hi Alan,

There have been around 20,000 downloads for Ninja RSS Syndicator in the few months we've been developing it... and thousands more over the year or so it was in development by the original developer.

Against that, it's strange that there are three major bugs that have been reported in the past two weeks that would seemingly make the extension unusable.

Maybe people install it and never bother to check their feeds, or maybe the issues are caused by the environment, hence the relatively tiny number of bug-reporters.

I can confirm that Daniel has started on it, but he splits his time between a number of extensions and his day job so that doesn't imply a fix is imminent.

I'll keep you updated.

Mark

Link to this post 21 Dec 09

Hi Mate,

Any update with this?

Cheers,

Alan

Link to this post 21 Dec 09

Hi Alan,

Oops, forgot to mention...
A test version was released here two days ago.

It needs to be properly tested but we haven't had any feedback yet.

Cheers,
Mark

Link to this post 27 Dec 09

Hi Alan,

Have you had a chance to test the new Ninja RSS Version?

Thanks,
Daniel.

Link to this post 28 Dec 09

p.s. In the new version, if you set your cache time to 0 then it doesn't generate a file, instead using a Joomla view.

This will allow you to get around the file permission errors without exposing your directory to hackers with 777 permissions.

Link to this post 06 Apr 10

Hello,

Are there any news on this issue?


Thank you and
Best Regards,
Cristian.

Link to this post 06 Apr 10

Hi Cristian,

Which issue in particular are ***you*** having?

Thanks
Mark

Link to this post 06 Apr 10

Dear Mark,

I am getting the "Error creating feed file, please check write permissions." message when clicking on the feed link. On the other hand I have the standard joomla SEO features turned on. I understand (from this thread) that they are the cause for the problem (as I tried changing permissions).

Best regards,
Cristian.

Link to this post 07 Apr 10

Hi Cristian,

The SEF/SEO only affects the Joomla front-end and will not affect you ability to save feeds.

This is a permissions issue that you will find affects any Joomla extension that writes to your hard drive. I suggest you try turning on the Joomla FTP layer. Some instructions here.

If that fails, ask your host to be transferred to a Joomla-friendly server (one which runs phpsuexec or one of its alternatives).

Kind regards,
Mark

Link to this post 07 Apr 10

Hello Mark,

And thank you for your answer.

This is a permissions issue that you will find affects any Joomla extension that writes to your hard drive. I suggest you try turning on the Joomla FTP layer. Some instructions here.

I have done that and I'm still getting the same result. Which exactly are the directories where we need to have write access?

Best regards,
Cristian.

Link to this post 07 Apr 10

If that fails, ask your host to be transferred to a Joomla-friendly server (one which runs phpsuexec or one of its alternatives).

I have spoken with the hosting provider; phpsuexec module is enabled on the apache server on which joomla runs.

Best regards,
Cristi.

Link to this post 07 Apr 10

Hi Cristi,

If you have phpsuexec enabled, then you don't have permission issues... so someone is mistaken here. Have you had permission issues with any other Joomla extensions?

Please send login details to support at ninja forge dot com.

The directory that Joomla needs write access to is the one in which feeds are created. It is called "feeds" and can be found components/com_ninjarsssyndicator

Cheers
Mark

Link to this post 07 Apr 10

Hello Marc,

The directory that Joomla needs write access to is the one in which feeds are created. It is called "feeds" and can be found components/com_ninjarsssyndicator

I had a "feed" directory under "components/com_ninjarsssyndicator" (not "feeds"). I created one with 777 permissions but still the same problems.

Is there a log that shows additional info about the error?
I have version 1.0.9d

Please send login details to support at ninja forge dot com.

Login details + url to my joomla installation?

Best regards,
Cristian.

Link to this post 07 Apr 10

Probably not necessary.

Please login with FTP and check whether your user (the user you log onto the server with) is the user that owns that the feed folder.

Link to this post 09 Apr 10

Please login with FTP and check whether your user (the user you log onto the server with) is the user that owns that the feed folder.

The apache user is running as user "nobody". The owner of the "feed" folder is me. Is this the problem?

However it is curious that even after setting 777 for "feed" it still doesn't work. With 777, "nobody" should be able to write there.

My web hosting provider told me that the account could be moved on a server with fastcgi. I understand that this way, the scripts would run as user = me (instead of nobody). Would this solve the permissions problem?

Thank you.

Best regards,
Cristian.

Link to this post 09 Apr 10

Hi Cristian,

Yes, that would indeed solve your problem and it is what I suggested earlier (phpsuexec).

You mentioned you were running phpsuexec but this is not possible because it would not allow you to set 777 permissions on a folder.

So yes, switching to fastcgi/phpsuexec/etc is a good idea, and not just as a fix for Ninja RSS Syndicator.

Cheers
Mark

Forums Ninja RSS Syndicator Error creating feed file, please check write......